Nested code - blocks of code inside blocks of code - is eventually necessary, but increases complexity. This is why keeping the code as flat as
possible, by avoiding unnecessary nesting, is considered a good practice.
Merging if
statements when possible will decrease the nesting of the code and improve its readability.
Code like
IF something.
IF somethingElse. " Noncompliant
WRITE / 'hello'.
ENDIF.
ENDIF.
Will be more readable as
IF something and somethingElse. " Compliant
WRITE / 'hello'.
ENDIF.